OpenGL » Functionality requiring OpenGL ES 2.0 or WebGL 1.0

The following symbols are not defined when targeting OpenGL ES 3.0, WebGL 2.0 or desktop OpenGL.

Member Magnum::GL::Framebuffer::IncompleteDimensions
This restriction is only present in OpenGL ES 2.0, not in desktop GL or OpenGL ES 3.0 anymore. Note that, however, NVidia desktop drivers are known to emit this value (
Member Magnum::GL::Luminance
Not available in ES 3.0, WebGL 2.0 or desktop OpenGL. Use PixelFormat::Red instead.
Member Magnum::GL::Luminance
Not available in OpenGL ES 3.0, WebGL 2.0 or desktop OpenGL. Use TextureFormat::R8 instead.
Member Magnum::GL::LuminanceAlpha
Not available in OpenGL ES 3.0, WebGL 2.0 or desktop OpenGL. Use TextureFormat::RG8 instead.
Member Magnum::GL::LuminanceAlpha
Not available in ES 3.0, WebGL 2.0 or desktop OpenGL. Use PixelFormat::RG instead.
Member Magnum::GL::SRGB
Not available in ES 3.0, WebGL 2.0 or desktop OpenGL. Use PixelFormat::RGB instead.
Member Magnum::GL::SRGBAlpha
Not available in ES 3.0, WebGL 2.0 or desktop OpenGL. Use PixelFormat::RGBA instead.