This is a snapshot of a work-in-progress documentation theme. If you feel lost, miss something, or want to see the original Doxygen docs instead, head over to the archived version of this documentation page.

OpenAL

State of OpenAL support, version and extension requirements.

State of implementation of particular OpenAL extensions is in the following table.

Extension requirements

The Audio library requires at least stock OpenAL 1.1 with no extensions, but some specific functionality has greater requirements. Following is the list of features requiring specific OpenAL extensions.